SE PHP - SocialEngine Requirements

SocialEngine is designed to be installed on a web server with the following basic requirements:

Basic Requirements (SocialEngine Core)



PHP

Minimum

  • PHP 7.2

  • PHP extensions:

    • GD2

    • cURL

    • iconv

    • IntlChar (required for Unicode characters support for mobile apps)

    • Imagick (ImageMagick) required for gif image support and mobile device image rotation

  • MySQLi extension

  • Safe mode must be OFF

  • Register Globals must be OFF

  • Magic Quotes must be OFF

  • Memory limit: 32M+

  • Sendmail

  • OpenSSL ENABLED

  • PHP settings for upload_max_filesize at 15 and post_max_size at 15

Recommended

  • PHP 7.2

  • PHP extensions: dom

Optional Extensions

  • BC Math (speed boost)

  • JSON (speed boost)

  • mbstring (required for non-English support)

 
MySQL Database

Minimum

  • MySQL 5.7 newer

  • 1 available database

  • InnoDB table support

  • MySQLi

Recommended

  • MySQL 5.7.21 or newer



Web Server

Minimum

  • Apache-based VPS web hosting

Recommended

  • Apache-based VPS or dedicated web server

  • crontab

  • mod_rewrite (removes index.php, for SEO-friendlier URLs)

  • Memcached (speed boost)

  • Disable mod_security/mod_security2 

Notes:

  • Nginx is not supported.

  • MariaDB is not supported.

  • FastCGI is not supported.

  • It is recommended to disable open_basedir.

  • PHP 7.3 is not supported yet.

  • If hosting with AWS, do not enable AWS WAF as it interferes with sessions and login.

  • If using CloudFront, it can only be used for media files or it will interfere with sessions and login.

  • For VFS (Virtual File Storage), enable allow_url_fopen .

Plugin Requirements

Some SocialEngine plugins have optional requirements:

Chat Plugin

VPS or dedicated server - budget/shared servers may not handle a high volume of users chatting at the same time.

Video Plugin

  • FFmpeg (for encoding video) - without FFmpeg, users can still post YouTube and Vimeo videos. Your host can help with FFmpeg setup.

Need help with this stuff?

Contact us with any questions you have about these requirements, we'll be happy to help! Most modern hosting providers are compatible with SocialEngine but if in doubt you can contact them directly and refer them to this page.

Need a web hosting provider too?

Picking the right host is important, especially if you have plans for your network to grow large! We've had great experiences working with BryZar (and so have our clients) and recommend checking them out for SocialEngine-powered hosting.